#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x)" & @CRLF & _
"(?<=<td>)[^<>]+"
Local $sString = "<table style="width:100%">" & @CRLF & _
"<tr>" & @CRLF & _
" <th>FirstName</th>" & @CRLF & _
" <th>LastName</th>" & @CRLF & _
" <th>Age</th>" & @CRLF & _
"</tr>" & @CRLF & _
" <td>Jill</td>" & @CRLF & _
" <td>Nigam</td>" & @CRLF & _
" <td>25</td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")