import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ "(?<=<td>)[^<>]+";
final String string = "<table style=\"width:100%\">\n"
+ "<tr>\n"
+ " <th>FirstName</th>\n"
+ " <th>LastName</th>\n"
+ " <th>Age</th>\n"
+ "</tr>\n"
+ " <td>Jill</td>\n"
+ " <td>Nigam</td>\n"
+ " <td>25</td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}