const regex = /(?x)
(?<=<td>)[^<>]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)
(?<=<td>)[^<>]+', 'gm')
const str = `<table style="width:100%">
<tr>
<th>FirstName</th>
<th>LastName</th>
<th>Age</th>
</tr>
<td>Jill</td>
<td>Nigam</td>
<td>25</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}