// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x)
(?<=<td>)[^<>]+").unwrap();
let string = "<table style=\"width:100%\">
<tr>
<th>FirstName</th>
<th>LastName</th>
<th>Age</th>
</tr>
<td>Jill</td>
<td>Nigam</td>
<td>25</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}