#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9a-f]{1,4}:)+(([0-9a-f]{1,4})?:)+([0-9a-f]{1,4})(?= )"
Local $sString = "2a03:2880:30ff:4::face:b00c --" & @CRLF & _
"2600:387:f:4533::8 - - " & @CRLF & _
"2600:387:5:805::84 - -" & @CRLF & _
"2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -" & @CRLF & _
"2601:602:8b00:e50::c1f0 - -" & @CRLF & _
"2409:4042:112:8a7b::27bd:70b1 - -" & @CRLF & _
"2603:7000:a803:beb2:e0c0:3f:2a1b:5d60 - - " & @CRLF & _
"::1 - -" & @CRLF & _
":a:1 - -" & @CRLF & _
":bh:lh:1 - -" & @CRLF & _
"1:1:fEd1:1:abdc:1 - -" & @CRLF & _
"::ffff:192.0.2.128 - -" & @CRLF & _
"0000:0000:0000:0000:0000:0000:0000:0001 - -" & @CRLF & _
"2001:0db8:0000:0000:0000:ff00:0042:8329 - -" & @CRLF & _
"2001:db8:0:0:0:ff00:42:8329 - -" & @CRLF & _
"2001:db8::ff00:42:8329 - -" & @CRLF & _
"2001:0db8:0000:0000:0000:ff00:0042:8329 - -" & @CRLF & _
"2a03:2880:30ff:4::face:b00c --" & @CRLF & _
"2600:387:f:4533::8 - - " & @CRLF & _
"2600:387:5:805::84 - -" & @CRLF & _
"2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -" & @CRLF & _
"2600:387:0:80f::4a - - "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")