# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0-9a-f]{1,4}:)+(([0-9a-f]{1,4})?:)+([0-9a-f]{1,4})(?= )"
test_str = ("2a03:2880:30ff:4::face:b00c --\n"
"2600:387:f:4533::8 - - \n"
"2600:387:5:805::84 - -\n"
"2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -\n"
"2601:602:8b00:e50::c1f0 - -\n"
"2409:4042:112:8a7b::27bd:70b1 - -\n"
"2603:7000:a803:beb2:e0c0:3f:2a1b:5d60 - - \n"
"::1 - -\n"
":a:1 - -\n"
":bh:lh:1 - -\n"
"1:1:fEd1:1:abdc:1 - -\n"
"::ffff:192.0.2.128 - -\n"
"0000:0000:0000:0000:0000:0000:0000:0001 - -\n"
"2001:0db8:0000:0000:0000:ff00:0042:8329 - -\n"
"2001:db8:0:0:0:ff00:42:8329 - -\n"
"2001:db8::ff00:42:8329 - -\n"
"2001:0db8:0000:0000:0000:ff00:0042:8329 - -\n"
"2a03:2880:30ff:4::face:b00c --\n"
"2600:387:f:4533::8 - - \n"
"2600:387:5:805::84 - -\n"
"2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -\n"
"2600:387:0:80f::4a - - ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.