import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9a-f]{1,4}:)+(([0-9a-f]{1,4})?:)+([0-9a-f]{1,4})(?= )";
final String string = "2a03:2880:30ff:4::face:b00c --\n"
+ "2600:387:f:4533::8 - - \n"
+ "2600:387:5:805::84 - -\n"
+ "2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -\n"
+ "2601:602:8b00:e50::c1f0 - -\n"
+ "2409:4042:112:8a7b::27bd:70b1 - -\n"
+ "2603:7000:a803:beb2:e0c0:3f:2a1b:5d60 - - \n"
+ "::1 - -\n"
+ ":a:1 - -\n"
+ ":bh:lh:1 - -\n"
+ "1:1:fEd1:1:abdc:1 - -\n"
+ "::ffff:192.0.2.128 - -\n"
+ "0000:0000:0000:0000:0000:0000:0000:0001 - -\n"
+ "2001:0db8:0000:0000:0000:ff00:0042:8329 - -\n"
+ "2001:db8:0:0:0:ff00:42:8329 - -\n"
+ "2001:db8::ff00:42:8329 - -\n"
+ "2001:0db8:0000:0000:0000:ff00:0042:8329 - -\n"
+ "2a03:2880:30ff:4::face:b00c --\n"
+ "2600:387:f:4533::8 - - \n"
+ "2600:387:5:805::84 - -\n"
+ "2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -\n"
+ "2600:387:0:80f::4a - - ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}