use strict;
my $str = '2a03:2880:30ff:4::face:b00c --
2600:387:f:4533::8 - -
2600:387:5:805::84 - -
2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -
2601:602:8b00:e50::c1f0 - -
2409:4042:112:8a7b::27bd:70b1 - -
2603:7000:a803:beb2:e0c0:3f:2a1b:5d60 - -
::1 - -
:a:1 - -
:bh:lh:1 - -
1:1:fEd1:1:abdc:1 - -
::ffff:192.0.2.128 - -
0000:0000:0000:0000:0000:0000:0000:0001 - -
2001:0db8:0000:0000:0000:ff00:0042:8329 - -
2001:db8:0:0:0:ff00:42:8329 - -
2001:db8::ff00:42:8329 - -
2001:0db8:0000:0000:0000:ff00:0042:8329 - -
2a03:2880:30ff:4::face:b00c --
2600:387:f:4533::8 - -
2600:387:5:805::84 - -
2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -
2600:387:0:80f::4a - - ';
my $regex = qr/^([0-9a-f]{1,4}:)+(([0-9a-f]{1,4})?:)+([0-9a-f]{1,4})(?= )/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}