using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9a-f]{1,4}:)+(([0-9a-f]{1,4})?:)+([0-9a-f]{1,4})(?= )";
string input = @"2a03:2880:30ff:4::face:b00c --
2600:387:f:4533::8 - -
2600:387:5:805::84 - -
2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -
2601:602:8b00:e50::c1f0 - -
2409:4042:112:8a7b::27bd:70b1 - -
2603:7000:a803:beb2:e0c0:3f:2a1b:5d60 - -
::1 - -
:a:1 - -
:bh:lh:1 - -
1:1:fEd1:1:abdc:1 - -
::ffff:192.0.2.128 - -
0000:0000:0000:0000:0000:0000:0000:0001 - -
2001:0db8:0000:0000:0000:ff00:0042:8329 - -
2001:db8:0:0:0:ff00:42:8329 - -
2001:db8::ff00:42:8329 - -
2001:0db8:0000:0000:0000:ff00:0042:8329 - -
2a03:2880:30ff:4::face:b00c --
2600:387:f:4533::8 - -
2600:387:5:805::84 - -
2a02:120b:2c12:df00:bc9f:adfd:eac6:4011 - -
2600:387:0:80f::4a - - ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}