using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]{2,}(?:\h+[A-Z]{2,})?\b";
string input = @"1234 FIRSTNAME LASTNAME M 4321
1345 LASTNAME F 4621
8223 FIRSTNAME LASTNAME M 4256";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}