import Foundation
let pattern = #"\b[A-Z]{2,}(?:\h+[A-Z]{2,})?\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1234 FIRSTNAME LASTNAME M 4321
1345 LASTNAME F 4621
8223 FIRSTNAME LASTNAME M 4256
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)