import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z]{2,}(?:\\h+[A-Z]{2,})?\\b";
final String string = "1234 FIRSTNAME LASTNAME M 4321\n"
+ "1345 LASTNAME F 4621\n"
+ "8223 FIRSTNAME LASTNAME M 4256";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}