re = /\b[A-Z]{2,}(?:\h+[A-Z]{2,})?\b/
str = '1234 FIRSTNAME LASTNAME M 4321
1345 LASTNAME F 4621
8223 FIRSTNAME LASTNAME M 4256'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end