$re = '~\b[A-Z]{2,}(?:\h+[A-Z]{2,})?\b~';
$str = '1234 FIRSTNAME LASTNAME M 4321
1345 LASTNAME F 4621
8223 FIRSTNAME LASTNAME M 4256';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);