#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?![AEIOU])[A-Z]"
Local $sString = "dfsdfAAAABBBBCCCdfeABCDFEDGDFABCDEFGHI" & @CRLF & _
"測試大寫字母,但非母音" & @CRLF & _
"參考解答" & @CRLF & _
"" & @CRLF & _
"https://stackoverflow.com/questions/54799576/regex-filter-only-uppercase-consonants" & @CRLF & _
"範例一:前方A-Z的字符不可以是AEIOU" & @CRLF & _
"[A-Z](?<![AEIOU])" & @CRLF & _
"範例二:後放的A-Z不可以是AEIOU" & @CRLF & _
"(?![AEIOU])[A-Z]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")