const regex = /(?![AEIOU])[A-Z]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![AEIOU])[A-Z]', 'gm')
const str = `dfsdfAAAABBBBCCCdfeABCDFEDGDFABCDEFGHI
測試大寫字母,但非母音
參考解答
https://stackoverflow.com/questions/54799576/regex-filter-only-uppercase-consonants
範例一:前方A-Z的字符不可以是AEIOU
[A-Z](?<![AEIOU])
範例二:後放的A-Z不可以是AEIOU
(?![AEIOU])[A-Z]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}