$re = '/(?![AEIOU])[A-Z]/m';
$str = 'dfsdfAAAABBBBCCCdfeABCDFEDGDFABCDEFGHI
測試大寫字母,但非母音
參考解答
https://stackoverflow.com/questions/54799576/regex-filter-only-uppercase-consonants
範例一:前方A-Z的字符不可以是AEIOU
[A-Z](?<![AEIOU])
範例二:後放的A-Z不可以是AEIOU
(?![AEIOU])[A-Z]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);