import re
regex = re.compile(r"(?![AEIOU])[A-Z]", flags=re.MULTILINE)
test_str = ("dfsdfAAAABBBBCCCdfeABCDFEDGDFABCDEFGHI\n"
"測試大寫字母,但非母音\n"
"參考解答\n\n"
"https://stackoverflow.com/questions/54799576/regex-filter-only-uppercase-consonants\n"
"範例一:前方A-Z的字符不可以是AEIOU\n"
"[A-Z](?<![AEIOU])\n"
"範例二:後放的A-Z不可以是AEIOU\n"
"(?![AEIOU])[A-Z]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")