using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![AEIOU])[A-Z]";
string input = @"dfsdfAAAABBBBCCCdfeABCDFEDGDFABCDEFGHI
測試大寫字母,但非母音
參考解答
https://stackoverflow.com/questions/54799576/regex-filter-only-uppercase-consonants
範例一:前方A-Z的字符不可以是AEIOU
[A-Z](?<![AEIOU])
範例二:後放的A-Z不可以是AEIOU
(?![AEIOU])[A-Z]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}