#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^Starting(?:(?!Complete).)*?FAIL"
Local $sString = "Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah Complete" & @CRLF & _
"Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah FAIL" & @CRLF & _
"Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah Complete" & @CRLF & _
"Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah FAIL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")