const regex = /^Starting(?:(?!Complete).)*?FAIL/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Starting(?:(?!Complete).)*?FAIL', 'gms')
const str = `Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}