using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Starting(?:(?!Complete).)*?FAIL";
string input = @"Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}