import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Starting(?:(?!Complete).)*?FAIL";
final String string = "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah Complete\n"
+ "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah FAIL\n"
+ "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah Complete\n"
+ "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah FAIL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}