$re = '/^Starting(?:(?!Complete).)*?FAIL/ms';
$str = 'Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);