package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d+[A-Z]+)(\d+[-; ]+)(\d+\b)`)
var str = `987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68`
var substitution = "$1$2$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}