import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+[A-Z]+)(\\d+[-; ]+)(\\d+\\b)";
final String string = "987ABC11-15; 77; 877; 66-68\n"
+ "987ABC11-987ABC15; 77; 877; 66-68\n"
+ "987ABC11-987ABC15; 987ABC77; 877; 66-68\n"
+ "987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68\n"
+ "987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68\n"
+ "987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68";
final String subst = "$1$2$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}