$re = '/(\d+[A-Z]+)(\d+[-; ]+)(\d+\b)/i';
$str = '987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68';
$subst = "$1$2$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;