import Foundation
let pattern = #"(\d+[A-Z]+)(\d+[-; ]+)(\d+\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)