#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(\d+[A-Z]+)\d+[-; ]+\K(?=\d+\b)"
Local $sString = "987ABC11-15; 77; 877; 66-68" & @CRLF & _
"987ABC11-987ABC15; 77; 877; 66-68" & @CRLF & _
"987ABC11-987ABC15; 987ABC77; 877; 66-68" & @CRLF & _
"987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68" & @CRLF & _
"987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68" & @CRLF & _
"987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)