const regex = /(\d+[A-Z]+)\d+[-; ]+\K(?=\d+\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+[A-Z]+)\\d+[-; ]+\\K(?=\\d+\\b)', 'gi')
const str = `987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);