# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+[A-Z]+)\d+[-; ]+\K(?=\d+\b)"
test_str = ("987ABC11-15; 77; 877; 66-68\n"
"987ABC11-987ABC15; 77; 877; 66-68\n"
"987ABC11-987ABC15; 987ABC77; 877; 66-68\n"
"987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68\n"
"987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68\n"
"987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.