use strict;
my $str = '987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68';
my $regex = qr/(\d+[A-Z]+)\d+[-; ]+\K(?=\d+\b)/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";