re = /(\d+[A-Z]+)\d+[-; ]+\K(?=\d+\b)/i
str = '987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result