using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"These\s+are\s+my\s+variables(?:\s*-(\w+)\s+\$(\w+))*\s+for\s+(case\d)";
string input = @"
These are my variables -abc $def -geh $ijk for case1
These are my variables -lmn $opq -rst $uvw for case2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}