import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "These\\s+are\\s+my\\s+variables(?:\\s*-(\\w+)\\s+\\$(\\w+))*\\s+for\\s+(case\\d)";
final String string = "\n"
+ "These are my variables -abc $def -geh $ijk for case1\n\n"
+ "These are my variables -lmn $opq -rst $uvw for case2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}