re = /These\s+are\s+my\s+variables(?:\s*-(\w+)\s+\$(\w+))*\s+for\s+(case\d)/
str = '
These are my variables -abc $def -geh $ijk for case1
These are my variables -lmn $opq -rst $uvw for case2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end