const regex = new RegExp('These\\s+are\\s+my\\s+variables(?:\\s*-(\\w+)\\s+\\$(\\w+))*\\s+for\\s+(case\\d)', 'g')
const str = `
These are my variables -abc \$def -geh \$ijk for case1
These are my variables -lmn \$opq -rst \$uvw for case2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}