using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\A-Z\.])\w+[\.\w+]+\w+";
string input = @"htt:pubhorn.co
www.pubhorn.co
htt://pubhorn.co
pubhorn.co/awawa
john.blogspot.co
htt://z--z.co/
www.man-whole.co
htt://yongqing.is-programmer.co/ewr
man-whole.co
www.man-world-wide.co/werwer
man-world-wide.co/werwerwer";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}