package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\A-Z\.])\w+[\.\w+]+\w+`)
var str = `htt:pubhorn.co
www.pubhorn.co
htt://pubhorn.co
pubhorn.co/awawa
john.blogspot.co
htt://z--z.co/
www.man-whole.co
htt://yongqing.is-programmer.co/ewr
man-whole.co
www.man-world-wide.co/werwer
man-world-wide.co/werwerwer`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}