re = /([\A-Z\.])\w+[\.\w+]+\w+/i
str = 'htt:pubhorn.co
www.pubhorn.co
htt://pubhorn.co
pubhorn.co/awawa
john.blogspot.co
htt://z--z.co/
www.man-whole.co
htt://yongqing.is-programmer.co/ewr
man-whole.co
www.man-world-wide.co/werwer
man-world-wide.co/werwerwer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end