// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([\A-Z\.])\w+[\.\w+]+\w+").unwrap();
let string = "htt:pubhorn.co
www.pubhorn.co
htt://pubhorn.co
pubhorn.co/awawa
john.blogspot.co
htt://z--z.co/
www.man-whole.co
htt://yongqing.is-programmer.co/ewr
man-whole.co
www.man-world-wide.co/werwer
man-world-wide.co/werwerwer";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}