import re
regex = re.compile(r"([\A-Z\.])\w+[\.\w+]+\w+", flags=re.IGNORECASE)
test_str = ("htt:pubhorn.co\n"
"www.pubhorn.co\n"
"htt://pubhorn.co\n"
"pubhorn.co/awawa\n"
"john.blogspot.co\n"
"htt://z--z.co/\n"
"www.man-whole.co\n"
"htt://yongqing.is-programmer.co/ewr\n"
"man-whole.co\n"
"www.man-world-wide.co/werwer\n"
"man-world-wide.co/werwerwer")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")