using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\wа-я]* (?:(?:[а-я]\w)|(?:\w[а-я])) [\wа-я]*";
string input = @"aaa
bbb
a1c
zzяяzzяя qwe1фasd фывйфыф1
п1п
wwя
я12
яяя
1я
1яa";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}