use strict;
my $str = 'aaa
bbb
a1c
zzяяzzяя qwe1фasd фывйфыф1
п1п
wwя
я12
яяя
1я
1яa';
my $regex = qr/[\wа-я]* (?:(?:[а-я]\w)|(?:\w[а-я])) [\wа-я]*/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}