// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)[\wа-я]* (?:(?:[а-я]\w)|(?:\w[а-я])) [\wа-я]*").unwrap();
let string = "aaa
bbb
a1c
zzяяzzяя qwe1фasd фывйфыф1
п1п
wwя
я12
яяя
1я
1яa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}