import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\wа-я]* (?:(?:[а-я]\\w)|(?:\\w[а-я])) [\\wа-я]*";
final String string = "aaa\n"
+ "bbb\n"
+ "a1c\n"
+ "zzяяzzяя qwe1фasd фывйфыф1\n"
+ "п1п\n"
+ "wwя\n"
+ "я12\n"
+ "яяя\n"
+ "1я\n"
+ "1яa";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}