re = /[\wа-я]* (?:(?:[а-я]\w)|(?:\w[а-я])) [\wа-я]*/xm
str = 'aaa
bbb
a1c
zzяяzzяя qwe1фasd фывйфыф1
п1п
wwя
я12
яяя
1я
1яa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end