using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?s)th[^>]+l"">(.*?)<\/th>.*?<td>(.*?)<\/td>.*?<a id=""(.*?)""";
        string input = @"<th scope=""col"">1X2</th>
    <th scope=""col"" class=""goR"">Odds</th>
    </tr></thead>
    <tbody>
    <tr class=""row1"">
    <td>Fortuna Köln</td>
    <td class=""prc ""><label><a id=""MarketGroupListComponent25-selection-38225206.1"" />";
        
        foreach (Match m in Regex.Matches(input, pattern))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}