# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)th[^>]+l\">(.*?)<\/th>.*?<td>(.*?)<\/td>.*?<a id=\"(.*?)\""
test_str = ("<th scope=\"col\">1X2</th>\n"
" <th scope=\"col\" class=\"goR\">Odds</th>\n"
" </tr></thead>\n"
" <tbody>\n"
" <tr class=\"row1\">\n"
" <td>Fortuna Köln</td>\n"
" <td class=\"prc \"><label><a id=\"MarketGroupListComponent25-selection-38225206.1\" />")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.