// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)th[^>]+l">(.*?)<\/th>.*?<td>(.*?)<\/td>.*?<a id="(.*?)""#).unwrap();
let string = "<th scope=\"col\">1X2</th>
<th scope=\"col\" class=\"goR\">Odds</th>
</tr></thead>
<tbody>
<tr class=\"row1\">
<td>Fortuna Köln</td>
<td class=\"prc \"><label><a id=\"MarketGroupListComponent25-selection-38225206.1\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}